ホーム » Linux » mailbbs 写メールBBSがPHP5.3.xだと動かない!!

mailbbs 写メールBBSがPHP5.3.xだと動かない!!


--- 広告 ---
--- 広告 ---

あらかんおやじです。

レッツPHPで公開しているメール投稿型掲示板の「写メールBBS」は、あらかんおやじも感謝しながら使わせていただいています。

新たにLinuxサーバをインストールし、phpのバージョンも5.3.1にしたら写メールBBSがWebで表示されません。エラーログをみるとparse error になっているのでその部分を変更しました。

htmltemplate.inc

$str2=str_replace("[loop $m]",
"<?php for(\$cnt[\"$n\"]=0;\$cnt[\"$n\"]<count(\$val$ind);\$cnt[\"$n\"]++){ ?>",
$str2);

「<?php改行」の構文解析のところでエラーになるようなので、その部分を上記のように修正すれば動作します。

--- 広告 ---
--- 広告 ---

 

この記事に関連する記事一覧

目 次
最近の投稿
--- 広告 ---
--- 広告 ---
お問い合わせ